Error
When attempting to print to the ImageNow Printer, there's an error that pops up and prevents printing, displaying:
Unable to get CLSID of controller
Cause
In most cases, this problem is found after upgrading the Perceptive Content client to a new version on computers running Windows 7.
Solution
NOTE: You must be an administrator on the computer to resolve these issues. If you are not an administrator, contact the Help Desk for support.
- Completely exit the Perceptive Content client
- Repair the installation by running the client installer again, found at \\imagenow-prd\client\current
- Follow instructions in the Perceptive Content: Desktop Client Install / Upgrade article taking special care to run as administrator
- When prompted, choose the Repair option
- Click Next
- Click Install
- Allow the client some time to repair
Alternative Solution
If repairing the installation does not resolve the issue:
- Uninstall Perceptive Content
- Restart the computer
- Reinstall using the manual method in the installation guide: Perceptive Content: Desktop Client Install / Upgrade
For further assistance as needed, please submit a ticket for the Perceptive Content System.