Perceptive Content: Error - Save As Dialogs or No Prompt When Capturing with ImageNow Printer

Summary

Resolving the unexpected behavior of a file prompt when using the ImageNow Printer

Body

Error

When attempting to capture with the ImageNow Printer, the user is not prompted to select a capture profile, or is instead prompted with a Save As dialog.

 

Cause

The ImageNow Printer did not install correctly, has corrupted settings, or a batch ImageNow Printer profile is set as the default profile.

 

Solution

  1. Verify documents are not being captured in a Batch
    1. Open the Batches tab in Perceptive Content
    2. Identify any documents captured recently and process per business processes
    3. If this behavior is undesired, the default profile option will need to be unchecked. Send a ticket through the Perceptive Content System service to remediate

NOTE: These steps may require local administrator privileges. If you are not an administrator on your computer or do not feel comfortable modifying the registry, please contact the Help Desk for assistance.

  1. Uninstall the Perceptive Content client
  2. Restart the computer
  3. Reinstall the Perceptive Content client following the Perceptive Content: Desktop Client Install / Upgrade article, taking care to run the installer as an administrator

 

If re-installing the client with administrator privileges does not resolve the issue, check the following configurations:

  1. Verify registry settings are correct
    1. Click Start, type run and hit Enter
    2. Type regedit and run as an administrator
    3. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers\ImageNow Printer\PrinterDriverData
    4. Verify there is a key value for Scripting File, and that it includes the correct full path to the inowprint.ini file (C:\Program Files (x86)\ImageNow\etc\inowprint.ini)
       
  2. Verify the inowprint.ini settings are correct
    1. Navigate to C:\Program Files (x86)\ImageNow\bin64 and take note of the name of the DLL in the directory, either inowprint.dll or INowPrint64.dll
    2. Open C:\Program Files (x86)\ImageNow\etc\inowprint.ini
    3. In the Run section, ensure the RunAtEnd command is pointing to the correct DLL:
      • 32-bit: RunAtEnd command=<C:\Program Files (x86)\ImageNow\bin64\inowprint.dll>
      • 64-bit: RunAtEnd command=<C:\Program Files (x86)\ImageNow\bin64\INowPrint64.dll>
    4. Save and close inowprint.ini
       
  3. Verify the required C++ Redistributable Package is properly installed
    1. Navigate to \\imagenow-prd\client\current
    2. Copy client installer to desktop
    3. Run installer as an administrator
    4. Allow the package to install and complete the installation

 

For further issues, submit a ticket through the Perceptive Content System service and request assistance.

Details

Details

Article ID: 32421
Created
Thu 6/22/17 1:52 PM
Modified
Thu 5/20/21 8:45 AM

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